CMDBuild 3.3 Alfresco supported version

Does anyone know what is the supported version of Alfresco for cmdbuild 3.3? I tried community edition 6.2 GA, install is easy and I was able to configure it on cmdb, but I can upload anything, I get this error: org.apache.chemistry.opencmis.commons.exceptions.CmisObjectNotFoundException: Type ‘P:cmdbuild:classifiable’ is unknown!

I used the Docker Compose install method.

This version can be used normally:alfresco-content-services-community-full-installer-6.0.2.1-ea-linux-x64

1 Like

Thank you, I’ll give that version a try.

Hi! I was wondering if the version suggested above worked for you? I tried installing Alfresco manually without luck and plan to try again using the “Containerized Deployment”, so I am wondering which version was successfully in the end. Thanks!

Hi Rayyu, I haven’t had a chance to test the suggested version install yet. Not sure about the Containerized Deployment, haven’t seen that, but the Docker Compose install method I dont think it works, there are multiple duplicated config files spread among different folders, not sure which ones is alfresco really using. I´ll get back to this post as soon I can test again.

Hi mnbv7758, I was wondering if you could share the step-by-step on how you were able to get this to work for you, or point me in the direction of information that helped you. I am looking into the various way to install Alfresco, but I am finding so many variances and getting mixed up. Thank you!

Thanks for letting me know! The Containerized Deployment from my understanding is the installation using Docker Compose. It’s just what they called it on the Alfresco Website. I’m disappointed to hear it didn’t work. I will try it anyways and let you know if it’s worth a second go. I will check back to see if the suggested version works for you too.

I installed version 6.0.2.1 and did a bit of testing and got the same error: org.apache.chemistry.opencmis.commons.exceptions.CmisObjectNotFoundException: Type ‘P:cmdbuild:classifiable’ is unknown!

I went thru the technical manual several times and I don’t understand why cmdbuild keeps sending me that error, doesn’t seem to be an Alfresco issue.

On the DMS section of the technical manual on page 23 explains how to add two xlm files for custom categories, so I don’t think I have to go thru that process unless we want add something different than the default, on page 25 describes how to configure DMS service using cli, but that’s the same thing as setting it thru the GUI.

Btw, installing version 6.0.2.1 is more simple, just do ./ on the install file and follow the steps and that’s about it.

It is working now, I was able to set it up on a CentOS 8 server:

  1. Installed Alfresco version 6.0.2.1: ./alfresco-content-services-community-full-installer-6.0.2.1-ea-linux-x64.bin

  2. Configure firewall:
    sudo firewall-cmd --permanent --add-port=8080/tcp
    sudo firewall-cmd --permanent --add-port=8443/tcp
    sudo firewall-cmd --reload

  3. Check if service is running:
    yourIP:8080/share

  4. Create cmdbuild-model-context.xml and cmdbuildModel.xml into Alfresco server:
    vi /opt/alfresco/alfresco-community/tomcat/shared/classes/alfresco/extension/cmdbuild-model-context.xml

vi /opt/alfresco/alfresco-community/tomcat/shared/classes/alfresco/extension/cmdbuildModel.xml

Note: copy the script from the technical manual.

  1. Make sure you have an FTP client on CMDBuild server, if not:
    sudo yum install ftp

  2. Reboot Alfresco and cmdbuild servers

  3. On cmdbuild aministration module configure DMS
    image

Note: you can use the default in “web service path”, in my case I created a folder on root in Alfresco.

That’s it! hope this is helpful for some one.