Disable Ping Widget

Hi there, how can i disable the “ping widget is not implemented” message, or how can i activate the widget?

Yes, I also suffered from that issue. Looks like the previous widgets system has been replaced with a new system, and nothing provided to replace the originals.

I had to hack the database to remove references to the widget as there is nothing within the UI to do it post upgrade.

Find where it’s being used with…
SELECT * FROM public."_Widget"
Where “EndDate” is Null
AND “Active” is true
AND “Status” = ‘A’
ORDER BY “Id” ASC

And disable with…
UPDATE public."_Widget"
SET “Active”=false, “Status” = ‘N’
Where “EndDate” is Null
AND “Active” is true
AND “Status” = ‘A’

on this class PC i cannot delete this form widgets?

image

Thx for your reply. but this sql statement isn´t working for me. i get this message…

image

I just published the Postman collection on GitHub, so you can download it from there. It also contains some explanations for variables you need to set and some automation to store the session key.

github[dot]com/AudunWangen/PostmanCMDBuild

1 Like

I had this exact error after upgrade. I also tried to change it directly in the database, but didn’t manage to find out how. What worked for me was using the API and Postman. I recommend that method, because it is much safer.

Just install Postman and create a new Collection for CMDBuild:

  1. Create a request of type POST against {{cmdbuild_url}}/sessions?scope=service&returnId=true and this body to authenticate
    {
    username:"{{username}}"
    password:"{{password}}"
    }
  2. List the class info with another request (GET) and you’ll find the widget there:
    {{cmdbuild_url}}/classes/IPAddress?scope=service
    You have to use the session ID returned from the previous request in the Header of this request like this:
    Key: Cmdbuild-authentication
    Value: {{sessionid}}
  3. Copy the class (only the “data”-part) to notepad and remove the widget-part. I think it should look like “widget”: [] or something.
  4. Make a new request with PUT against {{cmdbuild_url}}/cards with Cmdbuild-authentication in the header and paste in the data-part from notepad into body

That should remove it. I can export my Postman collection and send it to you if you can’t figure it out.

1 Like

Check the structure of the _Widget table. You may not have a EndDate field.
Mine has been upgraded from earlier versions, so this may not exist on your environment.
You can actually drop the EndDate check. This is only restricting the update to non-historic entries so it only touches active widgets.
Just remove the “EndDate” is Null AND part so the Where part of the query reads:
Where “Active” is true AND “Status” = ‘A’

Bear in mind, this will disable every widget, but I am guessing you are in the same situation as me that you can’t do anything with any of the previous widgets following the upgrade.

If you have added widgets following the upgrade, you will need to adjust the query to filter only the PING ones, otherwise they will be disabled.

1 Like

thx chris, i had 2 entries with Status “A”. on both entries i set it to “N”. Then i reboot my server and all was fine. the message did not appear anymore.

Hello can you share your ping widget, I need too, it will be very usefully for this community. Thanks

Hi, i do not have this widget enabled. I disabled it

Do you have this widget? Please share it

hi, i do not know where i can find the widget.