CMDBuild Forum

Error with import template


Hope you are doing well.
I am useing cmdbuild-3.3.2 and I am configuring an import template. When saving the import template configuration, I get the error bellow:

org.cmdbuild.utils.ws3.utils.Ws3Exception: error processing request =< ws3rest:post:etl/templates >, caused by: org.cmdbuild.utils.ws3.utils.Ws3Exception: error processing request with handler = Ws3RequestMethodHanlder{$$EnhancerBySpringCGLIB$$c76446f0, method=create}, caused by: org.cmdbuild.utils.ws3.utils.Ws3FrameworkException: error building method args for handler = Ws3RequestMethodHanlder{$$EnhancerBySpringCGLIB$$c76446f0, method=create}, caused by: java.lang.IllegalArgumentException: missing required payload content

Can you please check the error, and share with me the solution.

best regards,

try to delete and create the template again

Hi Kvo,

Thanks for your reply.

I deleted the template and once created I get the same error.

The template I am creating, contains two attributes : DATE and TIME. and this error only occurs when trying to create a template with these two attributes. I mean, when I configure only DATE or TIME, I don’t get the error. I get it when I try to configure both on the same templates. So I could configure two templates each one with one of these attributes and my problem is temporary solved, because it works in previous versions.

I hope that I explained well the problem I am having so you can try to generate it and solve it.

Thanks a lot.