Images folder path

Hi there, in which folder are the png images stored? After my Update to 3.2, the images are lost!

In CMDBuild 3 the icons are stored in the database.

Hi, i use the same DB after updating cmdbuild. how could this possible, that the pictures fail? in this case i cannont understand why the pictures are deleted! Please help me!

something similar happens to youcmdb

Hi again, from which version did you upgrade to the 3.2?

Hi, i go from 3.1.1 to 3.2.

Hi, I’ve tried to replicate the error you are encountering locally on my computer but without success.
I’ve installed CMDBuild 3.1.1, uploaded some picture, updated to 3.2 and the pics are still there.
Do you mind checking if in the database you have the icons in the “_Upload” table?
Also could you please check if in cmdbuild.log any errors are displayed when you open the relation graph?

1 Like

Hi, the pics are still in the database under the “_Upload” table. you find my logfile attached, when i open the relation graph. i cannont find any errors. Please help! thx

cmdbuild.log (152.2 KB)

Could you also tell me what browser are you using and which version?
And if you can try also with a different browser.
Thanks in advance

ok, my standard browser is chrome Version 80.0.3987.132. i also tried it with firefox Version 73.0.1 => also the same problem, the icons fail.

We can’t recreate the issue you are encountering, if the database you are using is from a test instance and doesn’t have sensitive information, do you mind giving us a dump of it?

Hi, today i updated to Version 3.3, also in this version the images fail. In the pictures below, you can see the difference.

image

image

It is also impossible to add new pictures to my classes. company logo also cannont be added under system config / generel options

Please help!

Hi!
are you able to see the class icon in the administration module for that class?

image

i dont´t know what you mean?

image

Please, you need to be more specific when saying that something is not working, what do you mean it’s not working? Do you get any errors when uploading it?

It appears from the screenshots that the images cannot be loaded for some reason, could you please refresh your page and check the list of HTTP requests and find which ones are going in error and what error message do they provide? Thanks

localhost_access_log.2020-11-11.txt (1.6 KB) cmdbuild.log (12.2 KB) cmdbuild.log (12.2 KB)

This are all Logfiles. Before they were generated i tried to Upload a picture to the class “PC”

Could you also please attach here the image you were trying to upload for the class “PC”?

Headset PC

here are 2 examples

this pictures are still working in Version 3.1.1