Installation cmdbuild - how to startup?

I have installed on my centos 7
Apache Tomcat Version 9.0.41
psql (10.15)
posgist …etc.

I am trying to install cmdbuild ready2use 3.0 using java -jar ready2use-2.1-3.3-b.war and the process
is smooth and installed successfully. However when pop up message appear “do u want to restart?” every option that I chose will come to login screen.

How to solve this?

Does login screen work?
Have you tried admin / admin?
Could you describe step by step, what is the furthest point you have reached, and how does it loop?

Here is my step by step:

  1. installed postresql 10.15 --> done and successful
  2. installed postgis 2.5 --> done and successful
  3. install Tomcat Version 9.0.41 with default /opt/tomcat. --> done and successful, to startup the tomcat using ./opt/tomcat/bin/startup.sh and using port 8080
  4. Download ready2use 3.0. and extract it on /tmp.
  5. rename file ready2use.war into cmdbuild.war
  6. move comdbuild war to /opt/tomcat/
    7.on terminal execute java -jar cmdbuild.war
  7. pop up installation appear.
  8. click install cmdbuild 3.0
  9. tomcat dir: /opt/tomcat/cmdbuild_app
  10. tomcat port 8080
  11. using demo database
  12. the rest is default option
  13. installation is successful and on last pop up message. the installation is successful and do u want to restart tomcat?
  14. If I say yes --> di pop up is gone and come up with message error during startup tomcat.
  15. I have tried to startup tomcat manually using
    a. command: ./opt/tomcat/bin/startup.sh --> on browser http://ip_address:8080 --> come up with
    default tomcat webpage.
    b. using command: ./opt/tomcat/cmdbuild_app/bin/startup,sh --> on browser
    http://ip_address:8080 --> come up with default tomcat webpage.

Please tell me what should I do, if I want to see cmdbuild login page?

Thanks

First of all, every installed app should be in /tomcatpath/tomcat/webapps/, not in the tomcat/ homedir.

My guess would be to remove the installed cmdbuild instance and install it again at tomcat/webapps. Make sure to drop database from previous attempt.

Before starting new installation process, check whether tomcat manages to start.
$ Systemctl start tomcat.service
Is your fastest way to go.
If tomcat starts throwing weird errors, my choice after an hour or so was to reinstall tomcat. I have to say tho, I managed to mess a few things in it before finding my way around.

Anyways, when installation is done properly, You will find your cmdbuild at http://ip_address:8080/cmdbuild

protip1: get to know http://ip_address:8080/manager - it helps debugging, if tomcat sees an app etc.
protip2: however you name your app directory in webapps/ will be the name of the app. So if you go for webapps/mynewcmdb/(actual cmdbuild files)
the link will change to http://ip_address:8080/mynewcmdb

I have tried with your solution and it did not work. Perhaps I there was something missing on my previous message.
a5
I have attached my tomcat installation location: I use tomcat9 as user and groups. My tomcat location at /opt/yomcat9a. I use port 8080 for my tomcat. On cmdbuild installation I used port 8081 because it return error when using port 8080 because port 8080 is used by tomcat. the tomcat is running during cmdbuild installation. I store cmdbuild path to /opt/tomcat9a/webapps/cmdbuild_30.

I also attached the location of cmdbuild.

The cmdbuild installation is successful. I can see the cmdbuild apps on the tomcat apps manager.

However, I still can not see the cmdbuild login page. How can I solve this problem?
you may see on the attachment the screen shot.

Well, it seems you have not understood my previous post.
Honestly, I have never specified port on install.
First of all, you should try ip:port/cmdbuild_30 (since you named your app cmdbuild_30)
Next to try is to open cmdbuild from tomcat web manager. first column serves as a link to each app.

In case nothing works, I wrote a quick guide on deploy.
Whenever I deploy a new instance of the cmdbuild, the fastest way i found is

cd /path_to_tomcat/webapps
mkdir cmdb_03/
put cmdb.war in the cmdb_03 dir
jar -xvf cmdb.war
rm cmdb.war
systemctl restart tomcat
now in your web browser go to ip:8080/manager
log into the manager and see whether tomcat sees app as running. If yes, you can click on first column to go to the cmdbuild.
As you will see, the address of the page will be ip:8080/cmdb_03.

Did you happen to install Alfresco or some other DMS to handle attachments? Cause I’m having issues with that.

Actually I have not yet succedeed installing Alfresco. Will be done with that in 1-2 weeks, mby then I will be of more use.

As far as I know to set up alfresco you need another >tomcat instance<. It might resist a bit with port configuration, I will probably be going with a different VPS for that, just for the ease. Honestly, you might try your luck at some alfresco focused forums

Honestly, you might try your luck at some alfresco focused forums

I haven’t. TRUST ME.