Problem with fonts after upgrade

Hello,

after upgrading from version 2.3.4 to version 3.2.1 we’re getting this error when trying to export to PDF or CSV:

{“success”:false,“messages”:[{“level”:“ERROR”,“show_user”:false,“message”:“com.google.common.util.concurrent.UncheckedExecutionException: org.cmdbuild.report.ReportException: error loading jasper report context, caused by: org.cmdbuild.report.ReportException: error loading jasper report context, caused by: org.cmdbuild.report.ReportException: error setting font family property key =< normal > value =< org/cmdbuild/report/fonts/arial.ttf >, caused by: java.lang.reflect.InvocationTargetException, caused by: net.sf.jasperreports.engine.JRRuntimeException: java.io.IOException: Problem reading font data., caused by: java.io.IOException: Problem reading font data.”}]}

Looking inside the 2.3.4 war I noticed there was a folder in cmdbuild/WEB-INF/classes/fonts/ with this font and a fonts.xml file in cmdbuild/WEB-INF/classes/. I tried adding these to the 3.2.1 war but I’m getting the same error. I also tried putting these files in classes/org/cmdbuild/report/fonts/ like the error says but nothing.

The war is deployed on a tomcat 9.0.30 with jdk 11.0.7.

Any ideas how I could fix this?

Thanks!