Problem with setting a default search filter

When we define a global Search Filter using Administrator, according to the documentation we can specify for each user group if this filter is default for them.

The doc says:

“Default for groups”: it allows you to specify that the current filter is applied as default filter onto the above mentioned class for the selected groups (see also the TAB “Default filters” of Users and Groups)

But when I do that, nothing happens, no filters are active. But when I edit the Class and specify the same filter as “Default Filter” for the class, it works. The filter is applied automatically when we view the contents of the class.

Unfortunately that solution doesn’t work for us because we don’t want this filter to be the default filter for all groups.

How can we specify a default filter for a group in particular?

1 Like

Hi, first of all could you please tell us which version of CMDBuild are you using?
Also when creating a default filter for a specific role make sure that you set an active grant on that filter for the group in the panel “Search filter” under group and permissions.

1- We’re using v3.1
2- I created a filter, clicked on the checkbox for the role then saved. Then went in permissions, tab: Search Permissions, activated the filter. Then tested : the filter is not active.

I’ve quickly tested on version 3.3 and it works just fine, later today I will check in version 3.1.

Hello again, I did some tests and it appears to be a bug related to version 3.1, this bug has been fixed in later versions, it is suggested to upgrade to the latest one: CMDBuild 3.3.

Ok, thanks for the info.